hdu 1712 ACboy needs your help 分组背包

系统 1598 0

转载请注明出处: http://blog.csdn.net/u012860063

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1712

Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 
Sample Input
        
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 
Sample Output
        
3 4 6

题意:一開始输入n和m,n代表有n门课,m代表你有m天,
然后给你一个数组,val[i][j],代表第i门课,在通过j天去修,
会得到的分数。求在m天能得到的最大分数。

      #include <cstdio>
#include <cstring>
#define N 147
int max(int a, int b)
{
	if(a > b)
		return a;
	return b;
}
int main()
{
	int n,m,a[N][N],dp[N];
	int i, j, k;
	while(~scanf("%d%d",&n,&m)&&( n || m))
	{
		memset(dp,0,sizeof(dp));
		for(i = 1; i <=n ; i++)
		{
			for(j = 1; j <= m ;j++)
			scanf("%d",&a[i][j]);
		}
		for(i = 1 ; i <= n ; i++)//第一重循环:分组数
		{
			for(j = m ; j >= 1 ; j--) //第二重循环:容量体积
			{
				for(k = 1 ; k <= j ; k++) //第三重循环:属于i组的k
				{
					dp[j]=max(dp[j],dp[j-k]+a[i][k]);
				}
			}
		}
		printf("%d\n",dp[m]);
	}
	return 0;
}
    


hdu 1712 ACboy needs your help 分组背包


更多文章、技术交流、商务合作、联系博主

微信扫码或搜索:z360901061

微信扫一扫加我为好友

QQ号联系: 360901061

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描下面二维码支持博主2元、5元、10元、20元等您想捐的金额吧,狠狠点击下面给点支持吧,站长非常感激您!手机微信长按不能支付解决办法:请将微信支付二维码保存到相册,切换到微信,然后点击微信右上角扫一扫功能,选择支付二维码完成支付。

【本文对您有帮助就好】

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描上面二维码支持博主2元、5元、10元、自定义金额等您想捐的金额吧,站长会非常 感谢您的哦!!!

发表我的评论
最新评论 总共0条评论