[UVA] 10167 - Birthday Cake

系统 1430 0
  Problem G. Birthday Cake  

 

Background

Lucy and Lily are twins. Today is their birthday. Mother buys a birthday cake for them.Now we put the cake onto a Descartes coordinate. Its center is at (0,0), and the cake's length of radius is 100.

There are 2N (N is a integer, 1<=N<=50) cherries on the cake. Mother wants to cut the cake into two halves with a knife (of course a beeline). The twins would like to be treated fairly, that means, the shape of the two halves must be the same (that means the beeline must go through the center of the cake) , and each half must have N cherrie(s). Can you help her?

Note: the coordinate of a cherry (x , y) are two integers. You must give the line as form two integers A,B(stands for Ax+By=0), each number in the range [-500,500]. Cherries are not allowed lying on the beeline. For each dataset there is at least one solution.

Input

The input file contains several scenarios. Each of them consists of 2 parts: The first part consists of a line with a number N, the second part consists of 2N lines, each line has two number, meaning (x,y) .There is only one space between two border numbers. The input file is ended with N=0.

Output

For each scenario, print a line containing two numbers A and B. There should be a space between them. If there are many solutions, you can only print one of them.

Sample Input

 

    2

-20 20

-30 20

-10 -50

10 -5

0
  

Sample Output

    0 1
    

题解:暴力枚举+线性规划。A、B都是整数且范围为[-500,500],1<=N<=50,所以暴力枚举即可。统计一下直线一侧点的数目是否为N。注意有点在直线上的情况是不合法的。

代码:
      
         1
      
       #include<stdio.h>


      
         2
      
       #include<
      
        string
      
      .h>


      
         3
      
       #include<stdbool.h>


      
         4
      
      
         5
      
      
        int
      
      
         i,j,n,m,sum,


      
      
         6
      
           a[
      
        110
      
      ],b[
      
        110
      
      
        ];


      
      
         7
      
      
         8
      
      
        int
      
      
         9
      
      
        init()


      
      
        10
      
      
        {


      
      
        11
      
      
        int
      
      
         i;


      
      
        12
      
           m=
      
        2
      
      *
      
        n;


      
      
        13
      
      
        for
      
      (i=
      
        1
      
      ;i<=m;i++
      
        )


      
      
        14
      
           scanf(
      
        "
      
      
        %d%d
      
      
        "
      
      ,&a[i],&
      
        b[i]);


      
      
        15
      
      
        16
      
      
        return
      
      
        0
      
      
        ;


      
      
        17
      
      
        }


      
      
        18
      
      
        19
      
      
        int
      
      
        20
      
      
        main()


      
      
        21
      
      
        {


      
      
        22
      
      
        int
      
      
         i,j,k,f;


      
      
        23
      
      
        while
      
      (
      
        true
      
      
        )


      
      
        24
      
      
            {


      
      
        25
      
               scanf(
      
        "
      
      
        %d
      
      
        "
      
      ,&
      
        n);


      
      
        26
      
      
        if
      
      (n==
      
        0
      
      ) 
      
        break
      
      
        ;


      
      
        27
      
      
                init();


      
      
        28
      
               f=
      
        0
      
      
        ;


      
      
        29
      
      
        for
      
      (i=-
      
        500
      
      ;i<=
      
        500
      
      ;i++
      
        )


      
      
        30
      
      
                {


      
      
        31
      
      
        for
      
      (j=-
      
        500
      
      ;j<=
      
        500
      
      ;j++
      
        )


      
      
        32
      
      
                    {


      
      
        33
      
                        sum=
      
        0
      
      
        ;


      
      
        34
      
      
        for
      
      (k=
      
        1
      
      ;k<=m;k++
      
        )


      
      
        35
      
      
                        {


      
      
        36
      
      
        if
      
      ((i*a[k]+j*b[k])<
      
        0
      
      ) sum++
      
        ;


      
      
        37
      
      
        if
      
      ((i*a[k]+j*b[k])==
      
        0
      
      ) 
      
        break
      
      
        ;


      
      
        38
      
      
                        }


      
      
        39
      
      
        if
      
      (sum==
      
        n)


      
      
        40
      
      
                        {


      
      
        41
      
                            f=
      
        1
      
      
        ;


      
      
        42
      
                            printf(
      
        "
      
      
        %d %d\n
      
      
        "
      
      
        ,i,j);


      
      
        43
      
      
        break
      
      
        ;


      
      
        44
      
      
                         }


      
      
        45
      
      
                     }


      
      
        46
      
      
        if
      
      (f==
      
        1
      
      ) 
      
        break
      
      
        ;


      
      
        47
      
      
                 }


      
      
        48
      
      
            }


      
      
        49
      
      
        50
      
      
        return
      
      
        0
      
      
        ;


      
      
        51
      
      
        }


      
      
        52
      
    

 

    
      
         
      
    
  

[UVA] 10167 - Birthday Cake


更多文章、技术交流、商务合作、联系博主

微信扫码或搜索:z360901061

微信扫一扫加我为好友

QQ号联系: 360901061

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描下面二维码支持博主2元、5元、10元、20元等您想捐的金额吧,狠狠点击下面给点支持吧,站长非常感激您!手机微信长按不能支付解决办法:请将微信支付二维码保存到相册,切换到微信,然后点击微信右上角扫一扫功能,选择支付二维码完成支付。

【本文对您有帮助就好】

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描上面二维码支持博主2元、5元、10元、自定义金额等您想捐的金额吧,站长会非常 感谢您的哦!!!

发表我的评论
最新评论 总共0条评论