POJ ACM习题【No.1046】

系统 1643 0
Color Me Less
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15365 Accepted: 7186

Description

A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation

Input

The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line containing three -1 values.

Output

For each color to be mapped, output the color and its nearest color from the target set.

If there are more than one color with the same smallest distance, please output the color given first in the color set.

Sample Input

    0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1

  

Sample Output

    (0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)
  

 

此题没有什么难点,注意比对最小欧式距离时的逻辑。

 

 

    import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		String[] str;
		
		int[][] target = new int[16][3];
		int[] temp = new int[3];
		int minIndex = 0;
		double minValue = -1;
		double tempValue = 0;
		
		for(int i = 0; i < 16; i++)
		{
			str = cin.nextLine().split(" ");
			target[i][0] = Integer.valueOf(str[0]).intValue();
			target[i][1] = Integer.valueOf(str[1]).intValue();
			target[i][2] = Integer.valueOf(str[2]).intValue();
		}
		
		while(cin.hasNext())
		{
			minIndex = 0;
			minValue = -1;
			tempValue = 0;
			str = cin.nextLine().split(" ");
			temp[0] = Integer.valueOf(str[0]).intValue();
			temp[1] = Integer.valueOf(str[1]).intValue();
			temp[2] = Integer.valueOf(str[2]).intValue();
			
			if(temp[0]==-1 && temp[1]==-1 && temp[2]==-1)
				break;
			
			for(int i = 0; i < 16; i++)
			{
				tempValue = getEuclideanD(temp, target[i]);
				if(tempValue == 0)
				{
					minValue = tempValue;
					minIndex = i;
					break;
				}
				if(minValue == -1)
				{
					minValue = tempValue;
					minIndex = 0;
					continue;
				}
				if(minValue > tempValue)
				{
					minValue = tempValue;
					minIndex = i;
				}
			}
			
			System.out.println(
					"("+temp[0]+","+temp[1]+","+temp[2]+
					") maps to "+
					"("+target[minIndex][0]+","+
					target[minIndex][1]+","+
					target[minIndex][2]+")");
		}
	}
	
	private static double getEuclideanD(int[] p1, int[] p2)
	{
		double value = 0;
		
		value = Math.sqrt(Math.pow((p2[0]-p1[0]), 2) +
					Math.pow((p2[1]-p1[1]), 2) + 
					Math.pow((p2[2]-p1[2]), 2));
		
		return value;
		
	}

}

  
 

POJ ACM习题【No.1046】


更多文章、技术交流、商务合作、联系博主

微信扫码或搜索:z360901061

微信扫一扫加我为好友

QQ号联系: 360901061

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描下面二维码支持博主2元、5元、10元、20元等您想捐的金额吧,狠狠点击下面给点支持吧,站长非常感激您!手机微信长按不能支付解决办法:请将微信支付二维码保存到相册,切换到微信,然后点击微信右上角扫一扫功能,选择支付二维码完成支付。

【本文对您有帮助就好】

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描上面二维码支持博主2元、5元、10元、自定义金额等您想捐的金额吧,站长会非常 感谢您的哦!!!

发表我的评论
最新评论 总共0条评论