Ignatius's puzzle

系统 1566 0

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4935    Accepted Submission(s): 3359


Problem Description

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

 

Input

The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

 

 

Output

The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.

 

 

Sample Input

11 100 9999

 

 

Sample Output

22 no 43

 

 

Author

eddy

 

若对任意x成立,则当x=1时必然成立.若当x=1时成立,则对任意正整数x都成立.

观察题目中给出的式子可以看出每一项都有公因子x,所以f(x)必然是f(1)的x倍,若f(1)是65的倍数,则f(x)必然也是65的倍数.

      #include<stdio.h>


      
        int
      
      
         main()

{

    
      
      
        int
      
      
         k;

    
      
      
        while
      
       (scanf(
      
        "
      
      
        %d
      
      
        "
      
      ,&k)!=
      
        EOF)

    {

        
      
      
        if
      
       (k==
      
        1
      
       || (k%
      
        5
      
      !=
      
        0
      
       && k%
      
        13
      
      !=
      
        0
      
       && k%
      
        65
      
      !=
      
        0
      
      
        ))

        {

            
      
      
        for
      
       (
      
        int
      
       i=
      
        1
      
      ;;i++
      
        )

            
      
      
        if
      
       ((
      
        18
      
      +k*i)%
      
        65
      
      ==
      
        0
      
      
        )

            {

                printf(
      
      
        "
      
      
        %d\n
      
      
        "
      
      
        ,i);

                
      
      
        break
      
      
        ;

            }

        }

        
      
      
        else
      
       printf(
      
        "
      
      
        no\n
      
      
        "
      
      
        );

    }

    
      
      
        return
      
      
        0
      
      
        ;

}
      
    

 

Ignatius's puzzle


更多文章、技术交流、商务合作、联系博主

微信扫码或搜索:z360901061

微信扫一扫加我为好友

QQ号联系: 360901061

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描下面二维码支持博主2元、5元、10元、20元等您想捐的金额吧,狠狠点击下面给点支持吧,站长非常感激您!手机微信长按不能支付解决办法:请将微信支付二维码保存到相册,切换到微信,然后点击微信右上角扫一扫功能,选择支付二维码完成支付。

【本文对您有帮助就好】

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描上面二维码支持博主2元、5元、10元、自定义金额等您想捐的金额吧,站长会非常 感谢您的哦!!!

发表我的评论
最新评论 总共0条评论