hdu 4970 Killing Monsters

系统 1709 0

Killing Monsters

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 160    Accepted Submission(s): 86


Problem Description
Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R. Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in block 2 and the last in block 3.

A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.
Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.
 

Input
The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0 < Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi <= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.

The input is terminated by N = 0.
 

Output
Output one line containing the number of surviving monsters.
 

Sample Input
        
5 2 1 3 1 5 5 2 5 1 3 3 1 5 2 7 3 9 1 0
 

Sample Output
        
3
Hint
In the sample, three monsters with origin HP 5, 7 and 9 will survive.
 

Source
 


题解及代码:


官方的思路挺好:

hdu 4970 Killing Monsters


比赛的时候開始使用线段树来做,结果超时,然后换成树状数组来做,使用树状数组维护区间和,感觉和官方思路还是差上一线啊。

官方:

      #include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#define maxn 100010
using namespace std;
typedef long long ll;

ll delta[maxn];

int main()
{
    int n,m,l,r;
    ll v;
    while(scanf("%d",&n)&&n)
    {
        memset(delta,0,sizeof(delta[0])*(n+5));
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
           scanf("%d%d%I64d",&l,&r,&v);
           delta[l]+=v;
           delta[r+1]-=v;
        }
        for(int i=2;i<=n;i++)
        {
            delta[i]+=delta[i-1];
        }
        for(int i=n-1;i>=1;i--)
        {
            delta[i]+=delta[i+1];
        }
        int ans=0;
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf("%I64d%d",&v,&r);
            if(v>delta[r])
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

    


个人思路:

      #include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=100000+100;
LL n;
LL c1[MAX],c2[MAX];

LL lowbit(LL x)
{
    return x&(-x);
}

void Update(LL x,LL d,LL *c)
{
    while(x<=n)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}

LL Query(LL x,LL *c)
{
    LL sum=0;
    while(x>0)
    {
        sum+=c[x];
        x-=lowbit(x);
    }
    return sum;
}

int main()
{
    LL x,y,d,t,h;
    int m;
    while(scanf("%I64d",&n)&&n)
    {
        memset(c1,0,sizeof c1);
        memset(c2,0,sizeof c2);
        scanf("%d",&m);
        for(int i=0; i<m; i++)
        {
            scanf("%I64d%I64d%I64d",&x,&y,&d);
            Update(x,d,c1);
            Update(y+1,-d,c1);
            Update(x,x*d,c2);
            Update(y+1,-(y+1)*d,c2);
        }
        scanf("%d",&m);
        int ans=0;
        for(int i=0; i<m; i++)
        {
            scanf("%I64d%I64d",&h,&x);
            t=Query(n,c1)*(n+1)-Query(x-1,c1)*x-Query(n,c2)+Query(x-1,c2);
            if(h>t) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
    






hdu 4970 Killing Monsters


更多文章、技术交流、商务合作、联系博主

微信扫码或搜索:z360901061

微信扫一扫加我为好友

QQ号联系: 360901061

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描下面二维码支持博主2元、5元、10元、20元等您想捐的金额吧,狠狠点击下面给点支持吧,站长非常感激您!手机微信长按不能支付解决办法:请将微信支付二维码保存到相册,切换到微信,然后点击微信右上角扫一扫功能,选择支付二维码完成支付。

【本文对您有帮助就好】

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描上面二维码支持博主2元、5元、10元、自定义金额等您想捐的金额吧,站长会非常 感谢您的哦!!!

发表我的评论
最新评论 总共0条评论