问题一百二十七:Keep on Truckin

系统 1725 0

Description

Boudreaux and Thibodeaux are on the road again . . .

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

"We're not going to make it, I say!"

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?

Input

 

Input to this problem will consist of multiple data sets. Each data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.

The data sets end with a negetive integer.

 

Output

There will be exactly one line of output. This line will be:

   NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

   CRASH X

otherwise, where X is the height of the smallest underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler).
The height of the 18-wheeler is 168 inches.

Sample Input

 

    
      180 160 170

-1
    
  

 

Sample Output

 

    
      CRASH 160
    
  
  
    #include <stdio.h>



int main()

{

    int i;

	int j;

	int t;

	int flag;

	int num[3];



	while(scanf("%d", &num[0])!=EOF && num[0]>=0)

	{

	      scanf("%d %d", &num[1], &num[2]);

          

		  flag=0;



		  for(i=0; i<2; i++)

		  {

		     for(j=i+1; j<3; j++) 

			 {

			     if(num[i]>num[j])

				 {

				    t= num[i];

					num[i]= num[j];

					num[j]= t;

				 }

			 }

		  }



		  for(i=0; i<3; i++)

		  {

		      if(num[i]<=168)

			  {

			      flag=1;

				  break;

			  }

		  }



		  if(flag)

		  {

		     printf("CRASH %d\n", num[i]);

		  }

		  else

		  {

		      printf("NO CRASH\n");

		  }

	}

    

    return 0;

}
  
    
  
    
      问题一百二十七:Keep on Truckin
    
  

问题一百二十七:Keep on Truckin


更多文章、技术交流、商务合作、联系博主

微信扫码或搜索:z360901061

微信扫一扫加我为好友

QQ号联系: 360901061

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描下面二维码支持博主2元、5元、10元、20元等您想捐的金额吧,狠狠点击下面给点支持吧,站长非常感激您!手机微信长按不能支付解决办法:请将微信支付二维码保存到相册,切换到微信,然后点击微信右上角扫一扫功能,选择支付二维码完成支付。

【本文对您有帮助就好】

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描上面二维码支持博主2元、5元、10元、自定义金额等您想捐的金额吧,站长会非常 感谢您的哦!!!

发表我的评论
最新评论 总共0条评论