【PAT】1035. Password (20)

系统 1938 0

题目: http://pat.zju.edu.cn/contests/pat-a-practise/1035

分析: 简单题。直接搜索,然后替换,不会超时,但是应该有更好的办法。

题目描述:

 

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

      3

Team000002 Rlsp0dfa

Team000003 perfectpwd

Team000001 R1spOdfa


    
Sample Output 1:
      2

Team000002 RLsp%dfa

Team000001 R@spodfa


    
Sample Input 2:
      1

team110 abcdefg332


    
Sample Output 2:
      There is 1 account and no account is modified


    
Sample Input 3:
      2

team110 abcdefg222

team220 abcdefg333


    
Sample Output 3:
      There are 2 accounts and no account is modified


    

 


参考代码:

 

    #include<iostream>

#include<string.h>

#include<string>

using namespace std;



class User

{

public:

	void set(string nam,string pas)

	{

		name = nam;

		pass = pas;

		is_Changed = false;

	};

	User(){};//此处要注意!!!如果写成User();则不能运行!

	

	void check();	

	void show();

	bool is_Changed;

private:	

	string name;

	string pass;	

	int len;

};



void User::show()

{

	cout<<name<<" "<<pass<<endl; 

}



void User::check()

{

	len = pass.length();

	int i;

	for(i=0; i<len; i++)

	{

		if(pass[i] == '1') {pass[i] = '@'; is_Changed = true;}

		else if(pass[i] == '0') {pass[i] = '%'; is_Changed = true;}

		else if(pass[i] == 'l') {pass[i] = 'L'; is_Changed = true;}

		else if(pass[i] == 'O') {pass[i] = 'o'; is_Changed = true;}

	}

}



int main()

{

	int N;

	int i;

	string nam,pas;

	int count = 0;

	cin>>N;

	User *u = new User[N];

	for(i=0; i<N; i++)

	{

		cin>>nam>>pas;

		u[i].set(nam,pas);

		u[i].check();

		if(u[i].is_Changed) { count++; }

	}

	if(count == 0)

	{

		if(N != 1)

			cout<<"There are "<<N<<" accounts and no account is modified"<<endl;

		else

			cout<<"There is 1 account and no account is modified"<<endl;

	}

			

	else

	{

		cout<<count<<endl;

		for(i=0; i<N; i++)

			if(u[i].is_Changed) u[i].show();	

	} 

	return 0;

}
  


 




 

【PAT】1035. Password (20)


更多文章、技术交流、商务合作、联系博主

微信扫码或搜索:z360901061

微信扫一扫加我为好友

QQ号联系: 360901061

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描下面二维码支持博主2元、5元、10元、20元等您想捐的金额吧,狠狠点击下面给点支持吧,站长非常感激您!手机微信长按不能支付解决办法:请将微信支付二维码保存到相册,切换到微信,然后点击微信右上角扫一扫功能,选择支付二维码完成支付。

【本文对您有帮助就好】

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描上面二维码支持博主2元、5元、10元、自定义金额等您想捐的金额吧,站长会非常 感谢您的哦!!!

发表我的评论
最新评论 总共0条评论