A hard puzzle

系统 1644 0

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23766    Accepted Submission(s): 8390


Problem Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

 

 

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

 

 

Output

For each test case, you should output the a^b's last digit number.

 

 

Sample Input

7 66 8 800

 

 

Sample Output

9 6

 

 

Author

eddy

 

 

Recommend

JGShining

 

      #include<stdio.h>


      
        int
      
       pow(
      
        int
      
       a,
      
        int
      
      
         b)

{

    
      
      
        if
      
       (b==
      
        0
      
      ) 
      
        return
      
      
        1
      
      
        ;

    
      
      
        if
      
       (b==
      
        1
      
      ) 
      
        return
      
      
         a;

    
      
      
        int
      
       x=pow(a,b/
      
        2
      
      
        );

    
      
      
        if
      
       (b%
      
        2
      
      ==
      
        0
      
      ) 
      
        return
      
       (x*x)%
      
        10
      
      
        ;

    
      
      
        else
      
      
        return
      
       (x*x*a)%
      
        10
      
      
        ;

}


      
      
        int
      
      
         main()

{

    
      
      
        int
      
      
         a,b;

    
      
      
        while
      
       (scanf(
      
        "
      
      
        %d%d
      
      
        "
      
      ,&a,&b)!=
      
        EOF)

    {

        a
      
      %=
      
        10
      
      
        ;

        printf(
      
      
        "
      
      
        %d\n
      
      
        "
      
      
        ,pow(a,b));

    }

    
      
      
        return
      
      
        0
      
      
        ;

}
      
    

 

A hard puzzle


更多文章、技术交流、商务合作、联系博主

微信扫码或搜索:z360901061

微信扫一扫加我为好友

QQ号联系: 360901061

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描下面二维码支持博主2元、5元、10元、20元等您想捐的金额吧,狠狠点击下面给点支持吧,站长非常感激您!手机微信长按不能支付解决办法:请将微信支付二维码保存到相册,切换到微信,然后点击微信右上角扫一扫功能,选择支付二维码完成支付。

【本文对您有帮助就好】

您的支持是博主写作最大的动力,如果您喜欢我的文章,感觉我的文章对您有帮助,请用微信扫描上面二维码支持博主2元、5元、10元、自定义金额等您想捐的金额吧,站长会非常 感谢您的哦!!!

发表我的评论
最新评论 总共0条评论